System requirements

Each part of a Deep Security deployment has its own system requirements.

Requirements vary by version. For older versions of agents, or relays, see their documentation:

Deep Security Manager

For a list of agents versions that are compatible with this version of Deep Security Manager, see Deep Security Manager - Agent compatibility by platform.

System component Requirements
Web browser

Cookies must be enabled.

  • Firefox 52.0.1+
  • Microsoft Internet Explorer 11+ or Edge
  • Google Chrome 57+
  • Apple Safari 9+ (for Mac)
Monitor 1024 x 768 resolution at 256 colors or higher

Deep Security Agent 10.3

System component Requirements

Minimum memory (RAM)

Total system memory


  • all protection enabled: 2 GB RAM (4 GB recommended)
  • Deep Security Relay feature only: 2 GB RAM (4 GB recommended)


  • all protection enabled: 1 GB RAM (5 GB recommended)
  • Deep Security Relay feature only: 1 GB RAM (4 GB recommended)
Requirements vary by OS version. Some versions may require less RAM. Less RAM is required also if you don't enable all Deep Security features.
Minimum disk space
  • all protection enabled: 1 GB
  • without anti-malware: 500 MB
  • Deep Security Relay feature only: 30 GB
Deep Security Relay must store packages for each of your agents' platforms. If you have many different platforms, more disk space is required.
Operating system

For compatible Docker and OS platforms, see Deep Security Manager - Agent compatibility by platform.

On supported versions of Microsoft Windows, you must have at least Powershell version 4.0 to run the agent deployment script.

Deep Security Notifier

If installed, Deep Security Notifier appears in the Windows system tray. If anti-malware is licensed and enabled, it indicates the statuses of Deep Security Agent. Supported platforms include:

  • Windows Server 2016 (64-bit)
  • Windows Server 2012 or 2012 R2 (64-bit)
  • Windows Server 2008 R2 (64-bit)
  • Windows Server 2008 (32-bit and 64-bit)
  • Windows 10 (32-bit and 64-bit)
  • Windows 8.1 (32-bit and 64-bit)
  • Windows 8 (32-bit and 64-bit)
  • Windows 7 (32-bit and 64-bit)
  • Windows XP (32-bit and 64-bit)